ShopSite Tip – USPS API Activation

You’ve configured the ShopSite USPS API but why is an error message showing up?

USPS Message: An XML response was not returned from USPS.

This is a very common problem because there is a step during the configuration settings that is easily missed when signing up for the USPS API.  If you do not contact the USPS after receiving your API login details and ask them to change your account to the production servers your account will stay in test mode, which will result in the error above.

What To Do

In ShopSite, on the Commerce > Shipping > Configure (for U.S. Postal Service) > Re-Subscribe USPS screen, Step 2 will have the details for what needs to be done, and Step 4 will have your User ID which was previously entered:

USPS – Re-Subscribe Screen

If you no longer have a copy of your original setup email from USPS, make a note of the User ID on your screen since it will be needed when you email them.

If you do have the original setup email, you can reference it for the details, but if not just send an email to “” with the following information:

I am requesting to have my USPS API account switched to the production servers.

API User ID: [put the user ID from the re-subscribe screen here]
API: USPS Web Tools Rate Calculators APIs
3rd-Party Cart: ShopSite

Thank You

That’s all there is to it.  The USPS Internet Customer Care Center is staffed from 7:00AM to 11:00PM Eastern Time and once they make the switch the USPS rates will begin returning correctly.

Looking for a web host that understands ecommerce and business hosting?
Check us out today!

Leave a Reply